What software is needed to use Mailock?

Mailock has the following requirements, depending on how you want to use it.

Outlook add-in:

  • Outlook 2010, 2013 or 2016 are supported. Office 365 requires the desktop applications to be installed. Windows 7 or higher.

Mailock Mobile

  • iOS version 9.x onwards
  • Android 4.4 onwards

Mailock Web

  • All common browsers including Chrome, Internet Explorer, Safari and Firefox.